SAP Knowledge Base Article - Public

2748170 - Routing Rule is Not Assigning The Tasks and Surveys Based in the Conditions Configured

Symptom

You have created a Routing Rule with Tasks and Surveys, however, they are not assigning the documents even when the conditions match.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Activity Planner work center.
  2. Click in the Routing Rules View.
  3. Open the Routing Rule XYZ (XYZ represents the name of the Routing Rule).
  4. Go to the Conditions Facet.
  5. Create your own Condition.
  6. Save and Close.
  7. Go to the Visits work center.
  8. Click on Visits view.
  9. Click on New.
  10. Create a Visit that matches with your condition maintained in the Routing Rule.
  11. Save and Open.
  12. Result: Routing rules does not assign the documents maintained in the Routing Rule.

Cause

If Routing Rules contains Organizational Unit, the visit should also contain the same Organizational Unit maintained in the routing rule. Otherwise it won't assign the documents maintained in the rule.

Resolution

This is expected system behavior. you can check what organizational unit is maintained in the following steps:

  1. Go to the Activity Planner work center.
  2. Click in the Routing Rule view.
  3. Open the Routing Rule XYZ.
  4. Click on Adapt in the top right of the screen.
  5. Select Edit Master Layout.
  6. Add the facet Organizational Units.

If you maintain an Organizational Unit for the routing rule, visit must belong to the same Organizational Unit maintained in the rule to start applying the conditions.

Keywords

Routing Rules ; Visit ; Activity Planner ; Tasks , KBA , LOD-CRM-ACT-VST , Visit Planning , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions