Symptom
Scheduled workflows are not getting executed if the condition is based on a custom field of type Date.
Environment
SAP CLOUD FOR CUSTOMER
Reproducing the Issue
-
Go to the Administrator work center.
- Go to the Workflow view.
- Create a New scheduled workflow rule and set your conditions.
- Result: Your active workflow does not create a task when the conditions are fulfilled.
Cause
This is the correct and desired behavior. We always take only UTC+0 time in consideration, because if we take the user's time instead of UTC then it might happen that for the same rule, if two users are using different time zones that will lead to inconsistency.The timestamp for many of the tasks in the system (such as Migration, Workflow Rules, etc.) is pulled from the system's backend, which is always in UTC+0 to avoid possible inconsistencies. Some of these dates and times will be filtered by the time set for your system, but others will continue to show as the "raw" time in the backend.The field type should also match the format 'date time'.
Resolution
Create a field of type Date/Time instead of just Date and that solves the issue.
Keywords
scheduled Workflow, Create, Task,Duration,field type,date,time , KBA , LOD-CRM-WKF , Workflow , Problem
Product
Attachments
Type_Date-Time2.png |