SAP Knowledge Base Article - Public

2748269 - Values in Replicated Business Partner Payload Not Showing in Longitude and Latitude Fields

Symptom

A Business Partner is replicated from an external system to C4C with the GeographicalLocation node included as below:

<GeographicalLocation>
    <GeographicalCoordinates>
        <LatitudeMeasure unitCode = "DD">XX.XXXXXXXXXXXX</LatitudeMeasure>
        <LongitudeMeasure unitCode = "DD">XX.XXXXXXXXXXXX</LongitudeMeasure>
    </GeographicalCoordinates>
</GeographicalLocation>

(Where X indicates a number for the measure.)

The fields Longitude and Latitude are empty in the associated Account.

Environment

  • SAP Cloud for Customer (C4C) 

Reproducing the Issue

  1. Replicate a Business Partner to C4C from external system with Longitude and Latitude information.
  2. Go to the Customers work center.
  3. Go to the Accounts view.
  4. The Latitude and Longitude fields are empty.

Cause

The unit of measurement for Degree is blocked in the system.

Resolution

  1. Go to the Business Configuration work center.
  2. Open activity Quantities and Units of Measure.
  3. Click Create and Maintain Physical Units.
  4. Set Activation Status to Released for Unit DD.

Keywords

units of measurement, longitude, latitude, degree, unit. , KBA , BC-SRV-ASF-UOM , Unit Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions