Symptom
The requirement is to set a phone type as 'business' and then make it read only, but the next added phone info row is also coming with phone type as read-only and it cannot be modified.
*Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
Employee Central - Rules
Employee Central - New hire
Reproducing the Issue
Add a new row in phone information and it comes as read-only as shown below:
OnInit rule used for above:
Cause
The data grid portlets like phone, email, pay-components, etc. visibility won't work as rule cannot distinguish the key and it sets the same visilibity in all rows.
Same cause as mentioned in KBA- 2704848 .
Resolution
- Create an onInit rule to set value of phone type to business and then create an onChange rule on one of mandatory fields like phone number which will set the phone type as read-only.
- Now when you add phone number, the phone type is made read-only and it happens only in that particular row you operated. Next row will still be editable.
- Also to try ensure that a business phone type is entered, you can raise an info message as well which reminds user to select business phone type during data entry.
Keywords
phone type, grid portlet, visibility rule, email visibility, phone visiblity, row visibility , KBA , LOD-SF-EC-PER-PRS , Personal Info - Config, Rules, RBP, UI , LOD-SF-EC-PER-EML , Email Info - Config, Rules, RBP, UI , LOD-SF-EC-PER-PHN , Phone Info - Config, Rules, RBP, UI , How To