SAP Knowledge Base Article - Public

2749439 - Landing Page Behavior

Symptom

  • Cannot update a Contact via Landing Page.
  • Error message is shown as "ID is not unique and can be shared; contact update not possible".

Environment

  • SAP Hybris Marketing Cloud – SAP Marketing Cloud

Reproducing the Issue

  1. Enter Email Address in Landing Page and set Permission flags.
  2. Submit the Landing Page.
  3. Error is shown and no changes are made to a Contact. "ID is not unique and can be shared; contact update not possible"

Cause

  • The input data is not sufficient to identify a contact.
  • Here is the system behavior:
    • The system first checks if the contact exists.
    • If the contact doesn't exist, it creates a new contact with whatever it gets from the Landing Page.
    • If the contact exists, the system checks the input data to search for the correct contact. If the input data is not sufficient to identify the contact, the error is raised.
    • If there are several contacts with the same email address, the system cannot decide which contact should be chosen.
    • This leads to the reported error.

Resolution

Create a Landing Page with more input values so the system can find only one contact to update the changes.

Keywords

Landing Page, Contact update not possible, Input , KBA , CEC-MKT-LPC , Content Studio: Landing Pages and Forms , CEC-MKT-DM-IC , Interaction Contact , Problem

Product

SAP S/4HANA Cloud 1811