SAP Knowledge Base Article - Public

2749713 - When Trying to Release Items on a Ticket to ERP The Following Error Message is Diplayed 'Item/s Not Released to ERP. Related Contract Not Yet Replicated to ERP'

Symptom

When trying to release Items on a Ticket to ERP, the following Error message is displayed:

'Item/s not released to ERP. Related contract not yet replicated to ERP'

Environment

SAP Cloud for Customer - Service

Reproducing the Issue

Pre-Requisite:

You have created a Service Contract and added Product ABC (ABC represents the Product ID) under Covered Objects for this Contract.

  1. Go to the Service work center.
  2. Select the Tickets view.
  3. Select Ticket XYZ (XYZ represents the Ticket ID).
  4. Select the Service and Repair facet.
  5. Highlight Product ABC.
  6. Select the Actions button.
  7. Select the option Release to ERP.

The following Error message is displayed:

'Item/s not released to ERP. Related contract not yet replicated to ERP'

Cause

The document type of the contract that is linked to the item is configured as relevant for external data / ERP replication.

You can check the setup by following these steps:

  1. Go to the Business Configuration work center.
  2. Select the Overview view.
  3. Search for and open the Activity Service Contracts.
  4. Select the Maintain Document Types hyperlink.
  5. Here you can see all the available document Types.

If the checkbox for External Data is selected, the document type is configured as relevant for external data / ERP replication.

The column External Data is set to X-True it means that you can synchronously request prices from ERP (via the UI Action to request pricing).

1. If the column replication is set to bi-directional it means that the contracts are and must be replicated between C4C and ERP. In this case, the contract is not usable in tickets if the contract is not properly replicated, The Goal is to avoid data inconsistencies between ECC and C4C.

2. If the column Replication is set to inbound it means that the contracts are sent in one direction from ERP to C4C. In this case, the Creation of the contract is only possible in ERP and Changes performed in C4C are not sent to ERP.

3.  If the column Replication is set to empty/blank it means that the contracts exist only in C4C.

You could understand each document type as a business scenario.
Dependent on your requirements, you could have to create multiple document types/business scenarios.

If your requirement is to get prices from ERP but the C4C Contract should not be replicated, you could then configure your document type with External Data set to X-True and Replication set tp empty/blank to fulfill this scenario.

Resolution

This is the standard system behaviour in SAP Cloud for Customer.

Keywords

Contract Covered Item Ticket Release ERP Error Document Type , KBA , LOD-LE-COP-SRV , Service Contract , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions