SAP Knowledge Base Article - Public

2749723 - Empty Line in Involved Parties of Sales Document

Symptom

You see an error upon opening a sales document 
Error: Main contact is initial. Delete it or enter an ID.

Environment

SAP Cloud for Customer

Reproducing the Issue

On this document, the steps will be given for opportunity, but it could occur in any sales document that contain parties.

  1. Go to the Sales work center.
  2. Go to the Opportunities view.
  3. Open an opportunity.

You will see the afore mentioned error

Cause

This is because of an empty line without defined data which is added in the involved parties

The system does not prohibit the creation of initial contact instances because it has no business impact and there are custom specific PDI implementations that rely on the possibility to create empty instances.

Additionally, you can check from involved parties facet and remove the empty line which is created as below

  1. Go to the Sales work center.
  2. Go to the Opportunities view.
  3. Open an opportunity.
  4. Go to the invovled parties facet.
  5. Select the empty invovled party line and delete it
  6. Select Save

Resolution

This is the standard behavior of the system.

An alternative option may be to check the SAP Customer Influencer Site to submit an idea.

Keywords

empty, involved party, sales, opportunities, Main contact, initial, Delete. , KBA , LOD-LE-RC-PAP , Party Processing , LOD-CRM-OPP , Opportunity Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions