SAP Knowledge Base Article - Public

2749809 - The Changes applied to a Parent Account are not displayed in the Child Account

Symptom

You have read about the 1902 feature “View Change History of Parent Account” in the Admin Guide. You can read: "Parent account changes are now displayed in the Changes tab in accounts".

However, when you apply a change in the parent account, you realize that this change does not appear in the Changes facet of the child account.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work center.
  2. Go to the Accounts work center.
  3. Click New.
  4. Fill in the mandatory data and the field “Top-Level Account” selecting ABC (ABC represents the name of the parent account).
  5. Click Save.
  6. Search and open the Parent account ABC.
  7. Go to the Account Hierarchy facet.
    Result: You will see that account ABC is the parent of account DEF (DEF represents the name of the child account that you have just created).

    AccountHierarchy.png
  8. Make a small change in the parent account. For instance, change the name from ABC to ABC123.
  9. Open the Child account.
  10. Go to the Changes facet.
    Result: You will not see any register where the parent account’s name was changed from ABC to ABC123.

ChangeParentAccount.png

Cause

This is not what the new feature is supposed to do.

We are supposed to see a register in the Child account>Changes facet mentioning that the parent account has been changed (from account ABC to another account). Changing the name of the parent account is not actually changing the parent account. Therefore, this change will not be shown in the changes facet inside the child account.

Resolution

The changes applied in the parent account will not be shown in the child account. This would be a new requirement.

If you want to check the "View Change History of Parent Account" feature, you can do the following:

  1. Go to the customers work center.
  2. Go to the Accounts work center.
  3. Click New.
  4. Fill in the mandatory data and fill in the field “Top-Level Account”.
  5. Click Save and open.
  6. Click the OVS next to the “Top-Level Account” field and select another account.
  7. Click Save.
  8. Go to the Changes facet.
    Result: You will see that you changed the parent account.

ChangeParentAccount2.png

Keywords

change, account hierarchy, parent account, child account, Top-Level Account , KBA , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions