SAP Knowledge Base Article - Public

2749906 - The Start Apply with LinkedIn Button Isn't Showing - SuccessFactors Recruiting

Symptom

Start Apply with LinkedIn 2.0 (AWLI) does not show the Sign In button when the candidate tries to apply:

AWLI1.png

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors Recruiting
  • SAP SuccessFactors Recruiting Marketing

Reproducing the Issue

  1. Go to the RMK Career Site
  2. Select a Posted Job
  3. Click on Apply Now
  4. Select Start Apply with Linkedin

Cause

  • This is caused by a misconfiguration between RMK and Recruiting settings
  • Respective locale is not enabled.

Resolution

  • To fix this issue we need to make sure Apply with Linkedin 2.0 is configured properly.
  • One of the reasons for this specific issue is related to the RMK Portal URL which is not set correctly in Provisioning
  • Enable the respective locale and enable social apply for that locale

***If you don't have access to Provisioning, please contact your Implementation Partner or Professional Services to have them do these steps***

  1. Verify the RMK Portal URL field and make sure there are no extra spaces or characters in the URL:

awli2.png

  1. Make sure the RMK Portal URL has the same value set under validJsSdkDomains in LinkedinIntegrationConfiguration within Manage Data in the Admin Center

awli3.png

Note: Please remember 1 LinkedIn account should be set to 1 environment (1:1), meaning Production and Test should have different accounts

See Also

KB article 2683467 - Apply with LinkedIn 2.0 - SuccessFactors Recruiting

Keywords

sf, success factors, RCM, RMK, linked in, missing, functionality , KBA , LOD-SF-RCM-INT , Integration Center & Intelligent Services , LOD-SF-RMK-INT , Int with RCM, Data Mapping, AwLi, Multilocation posting , Problem

Product

SAP SuccessFactors Recruiting all versions