Symptom
When trying to perform a Lifecycle Management (LM) process for a PDI solution, e.g. a solution deployment, and you receive an error message:
"Action not possible; life-cycle process locked by software change".
Environment
- Cloud for Customer
- Business ByDesign
- Cloud Applications Studio
Reproducing the Issue
- Open Cloud Applications Studio.
- Try to perform a solution deployment.
- Error Received: "Action not possible; life-cycle process locked by software change".
Cause
This error message is raised when you are trying to perform a lifecycle management activity while the system is currently being maintained by the Hosting/Operations team. The maintenance can be a upload of a software correction, internal maintenance, system upgrade, etc.
Resolution
As the system is being maintained you won't be able to do any activities on the system until the maintenance is completed. You would need to wait until the maintenance is finished and then proceed with the lifecycle management activity again.
If it exceeds more than Contractual Maintenance Period, then you can raise an incident asking to unclock the same.
Keywords
KBA , AP-RC-BDS-LM , ByDesign Studio Lifecycle Management , Problem