Symptom
You are using the service interface SurveyResponseMaintainBundleRequest and trying to add attachments to the survey via web service call and the system receives the communication but the attachment added to the payload is not available in the submitted survey.
Environment
SAP Cloud for Customer
Cause
Service SurveyResponseMaintainBundleRequest doesn't support response attachment.
Resolution
This is the current system behavior.
If you need the functionality to support response attachment urgently you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center.
You can find more details about the services offered by Cloud Service Center. You can contact Cloud Service Center as follows:
1. If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder.
2. If you are a customer: please use the little blue box “Contact Us” shown on the very right hand side of SAP Application Development Site, choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page.
Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.
An alternative option may be to check the SAP Customer Influencer Site to submit an idea.
Keywords
Web Service ; Survey ; Attachment ; Answer , KBA , LOD-LE-SUR-DEF , Survey definition = design time , How To