SAP Knowledge Base Article - Public

2751065 - Blank Error Message on Submitting LOA Request

Symptom

On submitting a leave of absence time type for user, a blank error message appears with no details

Checks:

  • No take rule on the selected time type which raises a message which has not been defined
  • Employee Time object has no Save rules which would a raise message

Environment

  • SAP SuccessFactors HCM Suite- All Versions
  • SAP SuccessFactors Employee Central - All Versions

Reproducing the Issue

  1. Navigate to Administer time UI
  2. Select New Absence on Time Records tab and select a LOA time type and the necessary dates
  3. Submit
  4. Blank error appears

Cause

On submitting a LOA, the system also check all job info rules.

  • Please navigate to Manage Business Configuration > Job Info

You may see an error here immediately, such as:

"You are not allowed to make changes to Job Information configuration due to following issue, Rules [**********] are not defined in the system but referenced in this configuration.
To resolve it, kindly configure these rules in the system using “Configure business rules” or delete them from the XML data model."

OR

  • Please run a check tool on EC - Core -> Rules to identify the rules that are incorrectly configured / needs to bee corrected

This is causing the blank error as the system checks all job info save rule for LOA time types.

Resolution

  • To resolve it, kindly configure the mentioned rules in the system using “Configure business rules” or delete them from the XML data model.
  • If you do not wish to configure the rule and are a customer with no access to Provisioning (if rule is not visible from Manage Business configuration), please log a case with support.

Keywords

empty error message, empty error in time off, blank message for LOA, blank error after saving leave of absence request , KBA , LOD-SF-EC-TIM , Time Off , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM all versions