Symptom
Reason for Status pop-up is missing when the custom status is used for Opportunities and Leads.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Sales work center.
- Go to the Opportunity or Lead work view.
- Open the Opportunity or Lead ABC (ABC represents the Object ID).
- Set the Status to a custom one.
- Result: The Reason for Status pop-up does not appear.
Cause
When a custom status is used, the Reason for Status field is available as a drop-down field in the Opportunity and Lead header screen, instead of a pop-up.
Resolution
To maintain the Reason for Status field, it needs to be enabled via Adaptation Mode as described on the following steps:
-
Go to the Sales work center.
- Go to the Opportunities or Leads work view.
- Open the Object ABC (ABC represents the Object ID).
- Click on Adapt and select Edit Master Layout.
- Hover the cursor over any field on the object header.
- Click on Add Items option and select Add Fields.
- Select Reason for Status field and click on Apply.
- Click on Adapt and select End Layout Changes.
Afterwards, the user may maintain a value on field Reason for Status.
Keywords
popup, new screen, UI, layout, adapt, customization, sales document , KBA , LOD-CRM-OPP , Opportunity Management , LOD-CRM-LM , Lead Management , How To
SAP Knowledge Base Article - Public