SAP Knowledge Base Article - Public

2751069 - Reason for Status Pop-Up is Missing When the Custom Status is Used

Symptom

Reason for Status pop-up is missing when the custom status is used for Opportunities and Leads.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center.
  2. Go to the Opportunity or Lead work view.
  3. Open the Opportunity or Lead ABC (ABC represents the Object ID).
  4. Set the Status to a custom one.
  5. Result: The Reason for Status pop-up does not appear.

Cause

When a custom status is used, the Reason for Status field is available as a drop-down field in the Opportunity and Lead header screen, instead of a pop-up.

Resolution

To maintain the Reason for Status field, it needs to be enabled via Adaptation Mode as described on the following steps:

  1. Go to the Sales work center.
  2. Go to the Opportunities or Leads work view.
  3. Open the Object ABC (ABC represents the Object ID).
  4. Click on Adapt and select Edit Master Layout.
  5. Hover the cursor over any field on the object header.
  6. Click on Add Items option and select Add Fields.
  7. Select Reason for Status field and click on Apply.
  8. Click on Adapt and select End Layout Changes.

Afterwards, the user may maintain a value on field Reason for Status.

Keywords

popup, new screen, UI, layout, adapt, customization, sales document , KBA , LOD-CRM-OPP , Opportunity Management , LOD-CRM-LM , Lead Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions