SAP Knowledge Base Article - Public

2752638 - Inactive Employee Replicated from Employee Central to C4C is Still Active

Symptom

An employee is set to inactive in Employee Central then it is replicated to C4C. In C4C the Employee is considered to be active.

Environment

  • SAP Hybris Cloud for Customer Add-ins

Reproducing the Issue

  1. In Employee Central set Employee ABC to Inactive (where ABC is the Employee ID).
  2. Replicate the Employee to C4C.
  3. In C4C go to the Administrator work center.
  4. Go to the General Settings View.
  5. Click on Employees.
  6. Filter based on Active Employees and search for Employee ABC.


Result: Employee ABC will appear as an active Employee.

Cause

In Employee Central there is an indicator that shows if an Employee is Active/Inactive. In C4C there is no indicator so the default behaviour is that the Employee is considered to be active based soley on the validity dates in the payload.

<EmployeeType>
  <ValidityPeriod>
    <StartDate>YYYY-MM-DD</StartDate>
    <EndDate>YYYY-MM-DD</EndDate>
  </ValidityPeriod>
</EmployeeType>

Resolution

This is expected system behaviour.

See Also

2322721 - How to create tickets for non-active employees

Keywords

employee replication, inactive employee, active employee, employee central, validity, validity dates , KBA , LOD-CRM-INT-EC , Integration of C4C with Employee Central , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions