Symptom
In the Web Service Message Monitoring view the error "Action FLAG_AS_OBSOLETE not possible; object does not exist" shows when trying to delete a Sales Arrangement.
Environment
SAP Hybris Cloud for Customer Add-ins
Reproducing the Issue
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Go to the Administrator work center.
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Go to the Web Service Message Monitoring view.
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Click View and Error Log.
Result: Error message is shown.
Cause
This error occurs when the actionCode for the Sales Arrangement is set to 05 and the LifeCycleStatusCode is set to 4:
<SalesArrangement actionCode="05" partnerFunctionListCompleteTransmissionIndicator="true">
<SalesOrganisationID>XXX</SalesOrganisationID>
<DistributionChannelCode>YYY</DistributionChannelCode>
<DivisionCode>ZZZ</DivisionCode>
<LifeCycleStatusCode>4</LifeCycleStatusCode>
Where XXX is the SalesOrganisationID, YYY is the DistributionChannelCode and ZZZ is the DivisionCode.
A LifeCycleStatusCode of 4 means obsolete. During the processing of the message the Sales Arrangement is deleted. The system will then try to obsolete the Sales Arrangement but will not be able to find it and an error will be created.
Resolution
The mapping for LifeCycleStatusCode should be set to 2 which is Active. This is standard in the CPI/PI mapping where the Sales Arrangement is deleted.
Keywords
lifecyclestatuscode, delete, obsolete, salesarrangement, sales arrangement, actioncode , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To