Symptom
- After adding a measure to your SAC story builder, error message: "Unable to retrieve data from the datasource" is displayed in the chart box.
- The following error message appears in the "Raw" tab (located in the bottom box on right-hand size) in the Fiddler Trace:
<html><head><title>Request Rejected</title></head><body>The requested URL was rejected. Please consult with your administrator.<br><br>Your support ID is:<YourSupportID><br><br><a href='javascript:history.back();'>[Go Back]</a></body></html>
Environment
SAP Analytics Cloud 2019.01 +
SAP BW/4HANA 1.0, SP10
Reproducing the Issue
- Log into SAC Tenant.
- Navigate to: "Main Menu" (3 horizontal dashes) > "Create" > "Story" > Select Desired Story Page Style > "Add Data" > "Data Acquired from an Existing Model" > Select Desired Model.
- Add a measure via the Builder to the chart.
- Notice error message: "Unable to retrieve data from the datasource ".
Cause
The data stack size has been exceeded on the platform where your system is hosted.
Resolution
- IF YOUR SYSTEM IS HOSTED ON HEC:
1. Use KBA: 1766704 to capture the HTTP/HTTPS Fiddler Traces.
2. Once captured, look for the following row:
- RequestMethod = POST
- InA =Query - ResultSet
- Result = 200
- Protocol = HTTP
- Host = <yourHost>
- URL <yourURL>
3. Click on this row and navigate to the top box on the right-hand side.
4. Above the top box click "Inspectors" and then above the box below, select "Raw".
5. Take a screenshot of this page, log a ticket with component LOD-ANA-BI and attach this screenshot to the ticket.
6. Highlight all the information that is present within the bottom box (below "Raw" tab) in the 'Problem Description' and reference this KBA.
- IF YOUR SYSTEM IS HOSTED ON AZURE / Other Cloud Hosting Service:
1. Use KBA: 1766704 to capture the HTTP/HTTPS Fiddler Traces.
2. Once captured, look for the row with the following details:
- RequestMethod = POST
- InA =Query - ResultSet
- Result = 200
- Protocol = HTTP
- Host = <yourHost>
- URL <yourURL>
3. Click on this row and navigate to the top box on the right-hand side.
4. Above the top box click "Inspectors" and then above the box below, select "Raw".
5. Take a screenshot of this page, and contact Azure / Other Cloud Hosting Service; ensure that you highlight all the information that is present within the bottom box (below "Raw" tab).
See Also
- How to find User Assistance for SAP Analytics Cloud?
- Ask a question on the SAP Community!
- 2487011 - What information do I need to provide when opening incidents with SAP Analytics Cloud (Hint: Use component LOD-ANA*)
Your feedback is important to help us improve our knowledge base.
Keywords
SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, EPM-ODS, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytic, BW/4HANA , KBA , LOD-ANA-BI , Business Intelligence Functionality, Analytic Models , LOD-ANA-PL , Planning , LOD-ANA-BR , SAC Boardroom , LOD-ANA-PR , SAC Predictive , Problem