SAP Knowledge Base Article - Public

2753323 - The Field "Employee" in the Advance Filter of Contacts Is Not Returning the Expected Results

Symptom

You are filtering Contacts related with the employee ABC (ABC represents the Employee Name) via advanced filter using the field "Employee", but you're not receiving the expected results.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work center.
  2. Go to the Contacts view.
  3. Click in the Advanced Filter.
  4. Enter the name of the employee ABC in the field "Employee".

You are expecting to retrieve only contacts where the employee ABC is part of the Contact Team, but you're retrieving contacts as result where the employee ABC is not part of the Contact Team.

Cause

Via the "Employee" advanced find form parameter, in the Contact advanced search is performed at 3 places:

  1. Account team of the account(s) linked to the contacts.
  2. Territory team of the accounts linked to the contacts.
  3. Contact team.

The employee ABC has been maintained in at least one of these three places.

Resolution

This is the expected system behavior.

Keywords

Contacts, Employee, Advanced Search, Advanced Filter , KBA , LOD-CRM-CON , Contact , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions