Symptom
When creating a new position or adding a Lower-Level position, the timezone field should be automatically populated based on the value that is taken from the Location.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
- Employee Central - Position Management
- Employee Central - Job Information
Reproducing the Issue
- Add custom field Timezone to Position object
- Add New Position
- Timezone is not populated
Cause
There is no configuration in place to ensure the custom Timezone field on the Position object is synced correctly when adding a new Position or Lower-Level Position.
Resolution
Adding a new Position
- Create a custom Timezone field on the Position Object configured with the Data Type String (as outlined in the handbook)
- Create an business rule that will sync the custom timezone field object from the Timezone field in Location
- Set this as an external rule for the location field on the Position object
- Save your configuration
Once the change is made to location when adding a new positon, the Timezone field will automatically be populated. (There needs to information in the Job Informtion time zone field in order for this to work)
Adding a Lower-Level Position
Open Position Management Settings -> UI Customizing -> Rule for Defining Copy-Relevant Position fields
Open this rule and add the following line:
Now, when adding a Lower-Level Position, this will rule will automatically populate the timezone field with the information taken from Location
See Also
https://help.sap.com/viewer/213711b5e5a847e2a20dfdd465346252/latest/en-US/794d3b2dae884b299030ee26a16db343.html
Keywords
sync, position, lower-level position, location, position, automatically, timezone , KBA , LOD-SF-EC-POS , Position Management , LOD-SF-EC-JOB , Job Information , Problem