SAP Knowledge Base Article - Public

2755147 - Address Information Change History Record displays "No Data" instead of Effective Date

Symptom

On the Address Information portlet upon clicking the History button, the data to the right side of the navigation pane is displayed correctly, but the Change History pane reads "No Data"

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

  • SAP SuccessFactors HCM Core - All Versions
  • SAP SuccessFactors Employee Central - All Versions

Reproducing the Issue

  1. Navigate to the users profile and click on the History button in the Address Information portlet
  2. The Change History pane on the left reads "No Data" instead of displaying the effective date, but the data exists and is displayed correctly on the PP3 page

AddressInfo_History.png

Cause

  • This happens when the Address type on the existing record has been made Inactive / Deleted on the Picklist : addressType.
  • On the snapshot included above, the Address listed is of type "home" and this is not active on the Picklist :

picklist.png

Resolution

  • Ensure that the picklist status is active for the value(s) where Address Information exists for the Address Types that are listed on the user's profile
  • If you would want the Picklist status to be Inactive, please re-create the Address Information with a different and an Active Address type

Keywords

SF, EC, Success factors, Employee Central, addresstype inactive, Home Address , KBA , LOD-SF-EC-PER , Person Data (All Person Data Types) , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Core all versions