Symptom
Business Rule is configured with a Workflow to show a message with “Warning” severity on Save after a change is made to Payment Information but after saving, no warning message is displayed.
When the message severity is set to “Info” or “Error” in the rule configuration the system works as expected and the respective message is displayed when data change is saved.
Rule trace on "Warning" severity message shows the message was triggered.
Environment
Employee Central - Payment Information, Business Rules
Reproducing the Issue
1. Configure a business rule to trigger a Workflow and display a "Warning" message when Payment Information is edited
2. Set rule as a Save Rule on Payment Information Object
3. Make a change to Payment Information that satifies the rule conditions
4. Workflow is triggered but no Warning message is displayed
5. Rule trace show both Workflow and Warning were triggered
6. Change severity of message to Info or Error and the rule will behave as expected
Cause
The reason for this is because when "Warning" message is set as "Save Rules", it will firstly process the Workflow part of the rule. On confirming the Workflow dialog, there's a parameter "warningAcknowledged" passed to the backend which will cause the warning message to be skipped.
Resolution
When raising a "Warning" severity message in combination with a Workflow, set the rule as "Validate Rules" on Payment Information Object.
Doing so will ensure that it will firstly go to the message rules processing. After the message is confirmed, then it will go to workflow processing ensuring both parts of the rule are processed.
See Also
Payment Information, Info, Rule, Warning, Message, Error, Not, Displayed, Shown, Trace, Workflow, Object, Save, onSave, trigger, display, proccessed, warningAcknowledged, skipped, triggered, edit
Keywords
KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , LOD-SF-EC , Employee Central , LOD-SF-EC-RUL , DO NOT USE - Business Rules & Event Derivation , Problem