SAP Knowledge Base Article - Public

2755501 - The Main Contact Flag Does Not Change When the Main Account Field is Enabled

Symptom

In the Relationships tab of a Contact, the Main flag of the relationnship does not get updated once the Main Account field is selected within the Contact Details.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work center.
  2. Go to the Contacts view.
  3. Open the Contact ABC (ABC represents the Contact ID).
  4. Go to the Relationships tab.
  5. Select the Contact relationship DEF (Contact relationship that is not flagged as Main).
  6. You can now see the Details section.
  7. Enable the ''Main Account'' field.
  8. The Main flag on the column Contact DEF is not selected after the ''Main Account'' field is checked.

Cause

This is the expected behaviour of the system.

Resolution

For a contact person relationship there are 2 main flags:

1. Main in the list of Relationship facet.

2.''Main Account'' in the details.

The first ''Main'' represents that the Contact is the main Contact of the Account. The second one represents which Account is the main Account of the Contact.

In order to update the header information of the Contact, you need to flag the ''Main Account'' of the details.

Keywords

KBA , LOD-CRM-CON , Contact , LOD-CRM-ACC , Account , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions