SAP Knowledge Base Article - Public

2755615 - User Faces RBAM Error Messages When Creating a New Territory

Symptom

The user ABC is trying to create a new Sales Territory, but the user ABC is faced with a RBAM: No authorization for WRITE error message (ABC represents the User ID).

Environment

SAP CLOUD FOR CUSTOMER

Reproducing the Issue

Example:

  1. Log into the system as user ABC
  2. Go to the Sales work center.
  3. Go to the Territory view.
  4. Click New.
  5. Fill in the required fields.
  6. Hit Save

Result: You are faced with two error messages

  • The system displays the error message: 'RBAM: No authorization for 'BuiltIn <default> WRITE' on instance 'ABC' of 'BONodeProxy <default> ROUTE <default> ROOT' in context 'UIApplication <default> /BYD_COD/SalesOnDemand/Visit/VisitRoute/Route_QC.QC.uicomponent <default> <default> Operation <default> Start''
  • Save Failed

Cause

The user who is trying to create a New Territory does not have the required authorizations: When it comes to Sales Territory management, the user needs unrestricted access on the Territory view.

This is user needs an assignment to the Administrator role to create new Sales Territories.

Resolution

You may ajdust the Role assignment or the access restriction of Sales territory for this user.

Keywords

RBAM: No authorization for 'BuiltIn <default> WRITE' on instance 'XYZ' of 'BONodeProxy <default> SALES_TERRITORY <default> ROOT' in context 'UIApplication <default> /BYD_COD/SalesOnDemand/Territory/UI/COD_Territory_QC.QC.uicomponent <default> <default> Operation <default> Start', Save Failed, Territory , Territory Creation. RBAM. , KBA , LOD-CRM-TM , Territory Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions