Symptom
'No Data' exist in Pay Type dropdown. Custom pay types has been configured but does not reflect in employees profile or under Manage Data > Payment Information.
Environment
- SuccessFactors Employee Central
- Payment Information
Reproducing the Issue
Manage Data > Create New > Payment Information > Add user > Click on Pay type drop down > No Data Exist
Cause
Custom pay types are associated to country. Root cause can be some data corruption within country object.
For example:Country object has two countries with same external code.
In Manage Data > Country > Search for country (say AUS), you will see two countries with same external code.
Resolution
- Check the country associated to the custom pay type.
- Navigate to manage data--->Search that country
- Making a dummy change (changing label) in one country (AUS) will resolve the issue.
If issue is still not resolved, kindly raise a support ticket.
Keywords
pay type, No data in pay type, custom pay type, payment informatiom, Duplicate external code, external code, same external code, country with same external code, , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , Problem