Symptom
Not possible to create new registered product, even main contact of account is active.
Environment
SAP Cloud for Customer .
Reproducing the Issue
-
Go to the Installed Base work center.
-
Go to the Registered Product view.
-
Click on the New Button.
-
In the New Registered Product screen, enter account as XYZ (where XYZ represent Account name).
An error Contact not valid; choose an active contact is trigger.
-
Now go to the Customer work center.
-
Go to the Account view and open account name XYZ .
-
Go to the Contact facet.
You can see the main contact of account XYZ is already with the status as active.
Cause
The Relationship Type as Ship-To for account XYZ is with status as Obsolete, which is causing an error on creating new registered product.
Resolution
- Go to the Customer work center.
- Go to the Account view and open account name XYZ .
- Go to the Relationships facet and click on value XYZ1 (where XYZ1 represent a Has Ship-To relationship type for account XYZ).
- Open business partner id XYZ1, you can see it is with status as obsolete.
- Click on action and change the status of XYZ1 from Obsolete to Active .
Now on creating new registered product for account XYZ, no more error will trigger.
Keywords
New Registered Product , Active Contact , Contact not valid , KBA , LOD-LE-IBA-IPO , Installation Point , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions