SAP Knowledge Base Article - Public

2756382 - Contact Created with Lower ID than the Configured Current Number

Symptom

You changed the Current Number for contacts in Business Configuration, however, when you create a new contact in SAP Cloud for Customer (C4C), you notice that the ID is lower than the new Current Number.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Business Configuration work center.
  2. Open activity: Integration of Business Partner Data from Your Cloud Solution to SAP ERP.
  3. Select Interval for Contact Replication.
  4. Click on the Change Current Number button.
  5. Change the number and save your settings.
  6. Go to the Customers work center.
  7. Open the Contacts view and create a new contact. Observe the ID, it might be lower than the new Current Number.

Cause

This behaviour usually occurs when there are still unused IDs in the "pool of allocated IDs". When a new document is created on a Business Object, C4C usually allocates about ten IDs in the application server (to avoid the usage of same IDs when many users are working on the same object etc.) and then it tries to use all those IDs and fill up the pool again. Therefore, once these allocated IDs are used, the current number will be considered.

Resolution

Create a few more contacts and observe the IDs, once the already allocated IDs are used, the new Current Number will be considered by C4C.

Keywords

current number, contact, ID , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions