SAP Knowledge Base Article - Public

2756651 - Invoice Run Takes a Long Time to Process or Finishes not Capturing all Expected Invoice Requests

Symptom

Your invoice run takes a long time to process and/or does not include all expected invoice requests .

Environment

SAP Business ByDesign

Cause

The work package size of this run is currently set to 1000. Due to the large amount of invoices and some errors within the invoice creation the system is not able to complete the run and this is causing the issue.

The system automatically schedules parallel work packages to speed up the processing time for a mass data run. With this value, you can reduce the maximum number of invoice requests per work package in case you get errors. The number needs to be between 50 and 1000.

Resolution

Create a new invoice run with the same parameter and reduce the Maximum Invoice Requests per Work Package to 50.

The field Maximum Invoice Requests per Work Package might be hidden in the Invoice Run screen.
You can make this field visible using the following steps:

  1. Go to the Customer Invoicing work center.
  2. Select the Invoice Runs view.
  3. Click on the New button and select the Invoice Run option.
  4. Select Personalize and choose This Screen.
  5. Click in the section Invoice Properties.
  6. Activate the check box for Maximum Invoice Requests per Work Package.
  7. Click on Save.
  8. Close the Personalize pane on the left.

Now create a new invoice run with the same parameters as the original run and set the original run to obsolete.

Keywords

Invoice Run, Processing, Long time to Finish; Performance; MDRO; missing Invoice , KBA , AP-CI-RUN , Customer Invoice Run , Problem

Product

SAP Business ByDesign all versions