Symptom
- You recieve an error when saving a new internal application.
- Error: 'Changes failed. null error(s) occurred.'
- We get the error message 'Your Work Has Not Been Saved! A system error occurred when attempting to map your information to system settings. Contact your Administrator for assistance.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Go to 'My candidate Profile'
- Change existing data or add new data
- Click 'Save'
- Get error message 'Your Work Has Not Been Saved! A system error occurred when attempting to map your infomation to system settings. Contact your Administrator for assistance.' 'Changes failed. null error(s) occurred.'
- Exception in the server log shows "cannot insert NULL or update to NULL: Not nullable "USERS_SYS_GENDER" column"
Cause
- The issue is being caused by a null gender field value.
- The database will not accept a null value for the gender field.
Resolution
You need to replace the null value with either one of the following values, "M", "F", " "(blank space).
- Take a new export of the UDF
- Go to Admin Centre > Manage Employees > Update User Information > Employee Export > Export User File
- Once the file has downloaded, open and go to the affected user
- In the Gender column enter one of accepted values "M", "F", " "(blank space)
- Save the file locally
- Re-import the data
- Go to Admin Centre > Manage Employees > Update User Information > Import Employee Data
- Choose Basic Import > Browse to the file you saved locally > Import data
- Alternatively, our engineers can run a script to update this field in the database directly (Internal: support please see PLA-7985 and SRSD-43839)
Keywords
PLA-8053, PLA-8197, PLA-7985, SRSD-43839, internal application error, changes failed, null error(s) occurred, , KBA , LOD-SF-RCM , Recruiting Management , LOD-SF-PLT , Platform Foundational Capabilities , Problem
Product
SAP SuccessFactors HXM Suite all versions