SAP Knowledge Base Article - Public

2757272 - Service Milestones are not Calcuated for Tickets Imported via Data Workbench

Symptom

When service tickets are imported using data workbench, in the UI you can see that those tickets do not have any milestones defined.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to Service Work center
  2. Select the Tickets view
  3. Search for ticket ABC (ABC is the id if the ticket imported via data workbench)
  4. Open the ticket
  5. In the Overview facet, go to section Timelines

Here you can see that the milestones like Completion Due, Next Response Due, and so on, are not determined for these fields.

Cause

Field for determining the milestone from datawork bench is imported in the date format.

Resolution

When you are creating/updating a ticket entry from data workbench, the Service Level is determined. However the milestone values are not calculated, because the milestone value of the field Reported On in data workbench is updated in date (DD:MM:YYYY) format instead of date-time(DD:MM:YYYY HH:MM:SS) format.

Keywords

Completion Due, Next Response Due, Service, SLA , KBA , LOD-LE-CSM-SVL , Service Level Objective , LOD-CRM-SRP , Service Request Processing , LOD-CRM-INT-DWB , Data Workbench , LOD-LE-SEE , Service Entitlements , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions