SAP Knowledge Base Article - Public

2757495 - System Becomes Unresponsive when trying to Create Business Role

Symptom

System becomes unresponsive when trying to create Business role with the Restriction Rule 99.

Environment

SAP Cloud for Customer

Reproducing the Issue


1. Go to Administrator work center and select Business Roles.
2. Select New and then Business Role.
3. Enter the Business Role ID.
4. Select Scope Manually and select Gobal from the dropdown.
5. In Work Center and View Assignments tab, Select the Work Center View ID SEOD_EMPLOYEE_SUPPORT_WCVIEW (Service).
6. Go to Access Restrictions Tab and select the view SEOD_EMPLOYEE_SUPPORT_WCVIEW.
7. Set the read and write access of the view to restricted.
8. Choose Restriction Rule: 99 – Define Specific Restrictions.
9. Once you select the Restriction rule, the system will become unresponsive.

Cause

Restriction rule 99 have limitations in terms of the data and volumes it can handle, especially when the restrictions are hierarchical by nature.
In order to construct the hierarchy, system needs to fetch the complete data. Since the data is huge in your system, it became unresponsive because of performance issues.

Resolution

Creating a business role with restrcition rule 99 is not advisable, when you have a huge volume of data in the system.
As a work around, you can use other restriction rules like Employee, Territories and Managed Service units based on your requirment.

Keywords

Restriction Rule 99, Access Restriction, Business Role, , KBA , SRD-CC-IAM , Identity & Access Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions