SAP Knowledge Base Article - Public

2757983 - Cannot Do Binding Of Custom Involved Party For Service Request Form In Adobe LiveCycle Designer

Symptom

You want to bind custom involved party in the template for Service Request in Adobe LiveCycle Designer. The party is not available.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Go to the Business Flexibility view.
  3. Search for Service Request template you want to edit.
  4. Download the template.
  5. Open the template in Adobe LiveCycle Designer.

You cannot do the binding for custom involved party ABC (ABC represents the involved party name).

Cause

Custom involved party ABC was not set up as Other Party in Business Configuration.

Resolution

To bring the custom involved party information in the Service Request form and map it to the other party structure, party role needs to be defined as Other Party.

  1. Go to the Business Configuration work centre.
  2. Go to the Implementation Projects view.
  3. Select respective implementation project.
  4. Click Open Activity List.
  5. Find Party Role Definition activity.
  6. Check if Party Category is set as other Party.

Then, to bind custom involved party, below points need to be fulfilled:

  • use the binding field called Other Party in the form message type.
  • table binding field: $.ServiceRequest.OtherParty[*]
  • this needs to be modeled as a table in the form template.

See Also

2545812 - Unable to bind a field using Adobe LiveCycle Designer (ALD), even when the data is available in xml.

2193339 - How to Download The XML For a Document From The Backend

Keywords

Other Party, Binding, Ticket, Form Template, Adobe LiveCycle Designer, Custom Party , KBA , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer add-ins 1811 ; SAP Cloud for Customer add-ins 1902