SAP Knowledge Base Article - Public

2758006 - Visit Timeline Does Not Show Opportunities

Symptom

You have noticed that Opportunities are not showing in the Visit timeline.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Visits work center.
  2. Choose visit ABC (ABC represents the visit ID).
  3. Open the visit and check the Account in visit.
  4. Click  the Account hyperlink.
  5. Go to the Opportunity facet.
  6. Check if there is one or more opportunities.
  7. Observe: There are many opportunities related to that account.
  8. Now go to the Visit and click Timeline.
  9. Observe: There will be task, sales quote, appointments and other objects but no opportunities.

Cause

The current goal of the interaction timeline is to display transactional details which might provide the appropriate context leading to the visit taking place. As opportunities span across long time periods with various dates of importance, we currently do not consider them within the timeline of interactions, the preceding opportunity related to the visit can still be viewed within the Related Items table.

Resolution

This is expected System behavior.

Keywords

Visits, timeline, Opportunity , KBA , LOD-CRM-OPP , Opportunity Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions