SAP Knowledge Base Article - Public

2758073 - Scheduled Workflow Rules Is Not Triggered for Activity Task

Symptom

Your scheduled Workflow Rule is not getting triggered for Activity Tasks created by a Workflow Rule action.

Environment

SAP Cloud for Customer

Reproducing the Issue

In this scenario, we will consider that we have a workflow rule that creates an Activity Task based in certain opportunity's condition and a scheduled workflow rule that should trigger when the Activity Task is created with Open status.

  1. Go to the Sales work center.
  2. Go to the Opportunities view.
  3. Click on New button.
  4. Create an opportunity that fulfill the workflow rule conditions.
  5. Open this opportunity.
  6. Go to the Sales Activities facet.
  7. Open the activity task created via the workflow rule.
  8. Go to the Workflow Changes facet under the task.
  9. You will see that the scheduled workflow rule did not get triggered, even though the workflow rule condition was fulfilled.

Cause

This scenario is not supported. Any workflow rule defined on Activity will not execute when the activity is created via workflow at the time of creation to avoid scenarios like recursion where it might end up in loop and will keep on creating/updating the activities again and again.

Resolution

This is the standard behavior of the system.

Though once the activity is created via workflow, any update done on the activity either via workflow or manually will trigger the scheduled workflow rule as usual.

If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available.

Keywords

KBA , LOD-CRM-WKF , Workflow , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions