Symptom
You want to query accounts for their attachments via web service. You have created a communication scenario for the web service ManageAttachmentFolderIn based on the business object CUSTOMER. But when you execute the query the binary object within the XML response is empty.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite: You have at least one account with an attachment maintained. You have built a web service request based on the business object (BO) Customers.
You have executed a web service request similar to the one following via SOAP UI (ABC-123 represents the UUID of the attachment):
<soapenv:Header/>
<soapenv:Body>
<glob:AttachmentFolderDocumentFileContentByIDQuery_sync>
<AttachmentFolderDocumentFileContentSelectionByID>
<DocumentUUID>ABC-123</DocumentUUID>
</AttachmentFolderDocumentFileContentSelectionByID>
</glob:AttachmentFolderDocumentFileContentByIDQuery_sync>
</soapenv:Body>
Your response does not contain any attachment data and might contain the below:
- "Authorization role missing for service"
- "Document 123 does not exist"
Cause
The business object CUSTOMER cannot be used to query attachments which are added to an account.
Resolution
You have to create a new communication scenario which is based on the business object BUSINESS_PARTNER_TMPL.
Keywords
Manage Attachment Folder In, Web Service, Customer , KBA , AP-RC-DOC , Document Centric Application Service , Problem