Symptom
Task is not created with the subject configured on the workflow rule.
Environment
SAP Cloud for Customer
Reproducing the Issue
To reproduce the issue, the user should be logged in another language instead of English, for example Portuguese.
-
Go to the Administrator work center
- Go to the Workflow Rule work view.
- Click New.
- On the step 1 - Enter Basic Data, fill Description field, select Account on Business Object field and define On Create Only for Timing field.
- On the step 2 - Define Condition, set the condition as desire clicking Add Group.
- On the step 3 - Define Actions, on Rule Type field, select Activity Task option.
- Flag Always Create Activity Task, fill the subject field, maintain a Recipient or an Employee.
- On the step 4 - Review, click the Finish button and Activate button afterwards.
The user should create an account that will match the conditions defined.
Result: The workflow rule has been triggered, however the task has been created with a standard subject instead of the subject defined on the workflow rule.
Cause
The English language has not been maintained for the subject on the Activity Task creation.
Resolution
-
Go to the Administrator work center.
- Go to the Workflow Rule work view.
- Select the workflow rule that are triggering the activity task creation.
- On the step 3 - next to the subject field, click the All Language button and a pop-up will open.
- Click Add Row, select English under Language and maintain the correspondent subject.
- On the step 4 - Review, click the Finish button and Activate button afterwards.
See Also
SAP Admin Guide - Workflows
Keywords
Workflow Rule, Activity Task, Subject, Language. , KBA , LOD-CRM-WKF , Workflow , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions