Symptom
Business role ID (<ID of Role>) is reserved by another business role.
Environment
SAP S/4HANA Cloud
Reproducing the Issue
- Go to the Maintain Business Roles app
- Create a new role as a copy of another role, or from a template
- Specify the New Business Role ID for the new role
- Attempt to save the new role
- The error may be seen a this time
Cause
This can happen if the business role ID is already being used, it is not possible to have duplicate IDs
Resolution
Pick a unique ID for the business role that does not already exist in the system when creating a new role
Keywords
KBA , BC-SRV-APS-IAM , Identity and Access Management , Problem
Product
SAP S/4HANA Cloud all versions