Symptom
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Below errors appear when trying to enable custom IdP in SAP Analytics Cloud (SAC):
- "Sorry, we've encountered an error during the account verification setup. Please try again later."
- "We were not able to verify your account. Check your login credential and try again."
Environment
SAP Analytics Cloud (Enterprise Edition).
Reproducing the Issue
- In SAC, From the side navigation, go to : System -> Administration -> Security.
- Select Edit.
- In the 'Authentication Method' area, select SAML Single Sign-On (SSO) if it is not already selected.
- In the 'SAML Single Sign-On (SSO) Configuration' area, configure "Custom SAML IdP", as per the steps mentioned in the below guide:
- Enable a Custom SAML Identity Provider
- In step 4 (Confirm that the mapping is working), enter "<Your Unique Identifier>"
- Click "Verify Account" button.
>> Notice the below errors:
- "Sorry, we've encountered an error during the account verification setup. Please try again later."
- "We were not able to verify your account. Check your login credential and try again."
Cause
Multiple reasons for the failure of verifying account include:
- Incorrect IdP meatadata uploaded (See SAP KBA 2692774 & 2833096 & 3461594)
>> Notice the following error message in the 'Chrome Console' log : "uploadIdPMetadata failed with 500 status". - The validation attempt may have been used in the same browser session where some user has already been authenticated in SAC.
Resolution
- Ensure that the IdP metadata is uploaded in correct format according to SAP KBA 2692774 & 2833096 & 3461594
=> If still unsure where is incorrect with the IdP metadata, please create one incident to component LOD-ANA-AUT. - Ensure that the Verify Account step should be done in a completely new browsing session by copying the URL provided in the Verify Your Account dialog.
- Recommend using Incognito mode (Google Chrome) or InPrivate mode (Microsoft Edge) as this serves as a new browsing session where the user should be redirected to IdP logon page to enter credential.
- Always make sure an existing Incognito window is not already open and that the User has not already authenticated in SAC using a different logon token, as this may cause the Verify Account step to be successful even if SAML is not configured correctly.
See Also
- KBA : 2692774 - SAML self-service fails verifying the account with the custom identity provider in SAP Analytics Cloud
- KBA : 2833096 - Verify account with Custom SAML IDP fails in SAP Analytics Cloud (SAC)
- KBA : 3461594 - Error "We were not able to verify your account. Check your login credential and try again" happened when click Verify Account for step 4 of configuring custom IDP in SAP Analytics Cloud (SAC)
- KBA : 2411608 - SAP Analytics Cloud SAML authentication configuration *** Collective KBA ***
- KBA : 2569847 - Where can you find user assistance (help) for SAP Analytics Cloud to use, configure and operate it more effectively?
- KBA : 2487011 - What information do I need to provide when opening incidents with SAP Analytics Cloud (Hint: Use component LOD-ANA*)
- Ask a question on the SAP Community!
- SAP Analytics Cloud > Learning > Guided Playlists
- SAP Analytics Cloud > Learning > Guided Playlists > Getting Support
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Keywords
SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, EPM-ODS, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics, SAML, SSO, IdP, Verify, Account, enable, Authentication, AUT, uploadIdPMetadata , metadata , KBA , LOD-ANA-AUT , SAC Authentication / Login , Problem