SAP Knowledge Base Article - Public

2761078 - Failed to Verify Account when trying to enable custom IdP in SAP Analytics Cloud (SAC) *** Collective KBA ***

Symptom

  • Failed to Verify Account when trying to enable custom IdP in SAP Analytics Cloud (SAC) 
  • Possible error:
    • Message "We have encountered an error during the account verification setup" pops up
    • Message "We were not able to verify your account. Check your login credential and try again" pops up
    • A red border appears around Login Credential box

Environment

  • SAP Analytics Cloud, Enterprise Edition

Reproducing the Issue

  1. Login to SAC.
  2. Configure Custom SAML IdP as per SAP Analytics Cloud guide: https://help.sap.com/doc/00f68c2e08b941f081002fd3691d86a7/release/en-US/3651184dad944aa2b361ad029a7a8cae.html
  3. Perform Step 4, Enter Login Credential and then click Verify Account button.

Cause

There are multiple reason for the failure of verifing account:

  • Incorrect IdP meatadata uploaded (See SAP KBA 2692774 & 2833096 & 3461594)
    => In this case, you may notice message "uploadIdPMetadata failed with 500 status" in Chrome Console log.
  • Your validation attempt may have used in the same browser session where some user has already been authenticated in SAC.

Resolution

  • Ensure that the IdP metadata is uploaded in correct format according to SAP KBA 2692774 2833096 & 3461594
    => If you still don't know where is incorrect with your IdP metadata, please create one incident to component LOD-ANA-AUT.
  • Ensure that the Verify Account step should be done in a completely new browsing session by copying the URL provided in the Verify Your Account dialog.
    • We recommend using Incognito mode (Google Chrome) or InPrivate mode (Microsoft Edge) as this serves as a new browsing session where you should be redirected to IdP logon page to enter credential.
    • Please always make sure an existing Incognito window is not already open and that the User has not already authenticated in SAC using a different logon token, as this may cause the Verify Account step to be successful even if SAML is not configured correctly.

See Also

Your feedback is important to help us improve our knowledge base.

Keywords

SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, EPM-ODS, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics, SAML, SSO, IdP, Verify, Account, enable, Authentication, AUT, uploadIdPMetadata , metadata , KBA , LOD-ANA-AUT , SAC Authentication / Login , Problem

Product

SAP Analytics Cloud 1.0