SAP Knowledge Base Article - Public

2761452 - Custom Notifications Tasks are showing in Status Ready

Symptom

You have enabled your custom business object for Notification Rules. You have setup a workflow rule in the Cloud Solution to send a notification to recipient XYZ (XYZ represents the recipient name) but the notification never reaches the intended user.

You then review the Business Tasks that have been created and observe your custom notification task has status Ready.

Environment

  •  SAP Cloud for Customer

Reproducing the Issue

Prerequisites:

  • You have created a custom business object.
  • You have enabled this custom business object for Notification Rules (see help documentation for information).
  • You have created a workflow rule based on your custom business object to send a notification to recipient XYZ depending on conditions fulfilled.

 

To view Tasks:

  1. Go to the Administrator work centre.
  2. Go to the Business Task Management view.
  3. Execute the search for All Tasks.
  4. Filter as per requirement.
  5. Observe the results.

You will now see the workflow notification tasks that have been created in the tenant. You will also be able to see who the recipient of the task is supposed to be and the status Ready.

 

Cause

This behavior has multiple possibilities:

  • The user who is defined as the recipient does not have access rights to the work centre the workflow task is created for.
  • The user who is defined as the recipient does not have the work centre views IPAD OFFLINE and CC_COMMONPERSONALWORK assigned.
  • The UI that the task is referring to does not exist in the tenant.

 

The errors that are raised are standard pre-authorization checks that are executed while the task instance is created and processed. If any of the above is true, then the task will be created Successfully with determination of the recipient, but the process of assignment will fail.

This is why the status is set to Ready.

Resolution

To resolve this issue, you must ensure the above scenarios are fulfilled properly. Navigate to the Administrator work centre and review the user's Access Rights and Assigned Work Centres.

 

Keywords

BTM, Custom Notification, Status, Ready , KBA , AP-RC-BDS-BTM , ByDesign Studio Business Task Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions