Symptom
- Upon saving e-mail notification template via Admin Center > E-Mail Notification Template Settings, the template is being deselected.
- The e-mail notification is not being sent when the user is localed in a specific language
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Go to Admin Center > E-mail Notification Template Settings
- Select a template (e.g. Continuous Feedback Received Notification)
- Enable it by clicking the checkbox
- Once you hit Save Changes, after the page refreshed the template is being deselected
Cause
The e-mail template is not configured in the desired language.
Resolution
Click on the affected e-mail template and you will notice a warning message: You do not have a template created for the selected language and form template combination, this is the recommended XYZ locale template. The e-mail can't be sent out without the e-mail template is configured in the user's locale.
Please save the template under specific locale to remove this warning message and check the e-mail notification again.
Keywords
E-mail notification, deselected, e-mail, email, notification, not saving, unable, not saved, cannot, can not, you do not have a template created for the selected language and form template combination, locale, language, locale template , KBA , LOD-SF-PLT-NOT , Email Notifications , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-MTR-EML , Emails and Notifications , LOD-SF-CPM-EML , Emails and Notifications , LOD-SF-GM-EML , Emails, Notifications & Alerts , LOD-SF-PM-EML , Emails and Notifications , Problem