SAP Knowledge Base Article - Public

2763454 - Unable to use Event Reason in Cardinality function in Business Rule

Symptom

Unable to select Event Reason when Cardinality function is used.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP Successfactors Employee Central
  • SAP Successfactors Employee Central - Business Rule

Reproducing the Issue

  1. Navigate to Admin Center

    Admin center.PNG

  2. Navigate to Company Settings and Search for Configure Business Rules

    admin denter2.png

  3. Create New Business Rule

    admin center 3.png

  4. Click Basic and enter a unique Rule Name then select Base Object. Click Continue.

    admin center 4.png

  5. Select Cardinality from the drop down

    admin center 5.png

  6. Select Event Reason. Click + button or click Either Employee Status, Event, Follow-up Activity in Position. Notice that all of these are not clickable.

    admin center 6.png

Cause

Cardinality functionality is currently not supported for Event Reason.

Resolution

Cardinality Function is used to calculate the number of object instances found by a path. The path offers a collection filter that counts only the number of instances that match the filter condition.

If this is part of your business requirements, you can request for enhancement following this KBA:

2090228 - How to Submit Enhancement Requests for SAP SuccessFactors Products

See Also

Implementing Business Rules in SAP SuccessFactors - Cardinality

Keywords

Cardinality, Cardinality Function, Event Reason, Business Rule, Rule , KBA , LOD-SF-EC-JOB-RUL , Job Info Business Rules , LOD-SF-EC-FOO , Foundation Objects (Organisation, Pay and Job Structures) , Problem

Product

SAP SuccessFactors Employee Central all versions