Symptom
Unable to select Event Reason when Cardinality function is used.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP Successfactors Employee Central
- SAP Successfactors Employee Central - Business Rule
Reproducing the Issue
- Navigate to Admin Center
- Navigate to Company Settings and Search for Configure Business Rules
- Create New Business Rule
- Click Basic and enter a unique Rule Name then select Base Object. Click Continue.
- Select Cardinality from the drop down
- Select Event Reason. Click + button or click Either Employee Status, Event, Follow-up Activity in Position. Notice that all of these are not clickable.
Cause
Cardinality functionality is currently not supported for Event Reason.
Resolution
Cardinality Function is used to calculate the number of object instances found by a path. The path offers a collection filter that counts only the number of instances that match the filter condition.
If this is part of your business requirements, you can request for enhancement following this KBA:
2090228 - How to Submit Enhancement Requests for SAP SuccessFactors Products
See Also
Keywords
Cardinality, Cardinality Function, Event Reason, Business Rule, Rule , KBA , LOD-SF-EC-JOB-RUL , Job Info Business Rules , LOD-SF-EC-FOO , Foundation Objects (Organisation, Pay and Job Structures) , Problem