SAP Knowledge Base Article - Public

2763819 - My Inbox S4H - Missing timesheet records for approval

Symptom

Using My Inbox in S4Hana Cloud, timesheet records to be approved/rejected aren´t displayed. However, these records are available in "Approve Timesheet" App.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP S/4HANA Cloud

Reproducing the Issue

  1. An employee creates a timesheet record on Manage My Timesheet application and send it to the approver.
  2. Approver opens My Inbox application but any record is available there to be approved/rejected.

Cause

Customizing available in SSCUI "Manage your solution" app to require approval might be lost for the affected profile (S4H_INT for internal employees or S4H_EXT for contingent workers).

Resolution

Please find the steps below:

  1. Open "Manage your solution" application in your test system:

    tile.jpg

  2. Click on 'Configure your Solution':

    manage your solution.jpg

  3. Select Application Area 'Human Resources', sub application 'Time and Expense Management':

    config.jpg

  4. Open Configuration step 'Maintain Data Entry Profiles (S/4HANA), clicking on Configure button:

    config step.jpg

  5. Select affected profile, S4H_INT or S4H_EXT:

    select profile.jpg

  6. Uncheck the Approval checkbox:

    approval required.jpg

  7. Save the changes. Lock them in a transport
  8. Now Check the Approval checkbox in the same test system
  9. Save the changes
  10. The changes will get added to the same transport 
  11. Transport to production system
  12. Once the transport reaches production system, My Inbox will start to show up the pending approvals for new records created or existing records that are updated after following these steps

Important notes:

  • Although 'Approval Required' flag is already selected on the production system, customizing on the backend is inconsistent so please follow all these steps to solve this issue.
  • Older records which were posted before these changes will not appear in My Inbox; only the new ones will start to show in this application. The older entries will have to be approved from "Approve Timesheet" App.

See Also

My Inbox - Approve Timesheets

Keywords

KBA , CA-TS-S4 , Cross Application Timesheet in S/4HANA , Problem

Product

SAP S/4HANA Cloud 1902