Symptom
You preview a Balance Confirmation and you receive the error message: "XML Transformation failed".
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Receivables Work center.
- Go to the Customers View.
- Go to the Balance Confirmation subview.
- Show All Balance Confirmation and Find Balance Confirmation ID ABC. (ABC represents the Balance Confirmation ID).
- Choose Preview and Send options.
Error message: "XML Transformation failed".
Cause
This issue could be because of the number of overdue days have a very high value. Business byDesign can only consider < 999 days. To check this please follow the below steps:
- Go to the Receivables Work center.
- Go to the Customer Accounts subview.
- Go to the Trade Receivables subview.
- Show All Customers and find Customer Account ID DEF. (DEF represents the ID of the Customer Account).
- Open for Example Customer Invoice XYZ. (XYZ represents the Customer Invoice ID).
- Choose View.
- Go to the Trade Receivables work center and select the Invoices/Payments view.
Under Payment Terms/Due Dates you can see the Days Overdue: If there is more than 999 days, the error message occurs.
Resolution
If the Overdue Dates are 999 days or more you have to use the following workaround:
Instead of viewing the Balance Confirmation in the view you can download the details to Microsoft Excel.
- Go to the Receivables Work center.
- Go to the Customers view.
- Go to the Customer Accounts subview.
- Show All Customers and Find Account ID DEF.
- Choose view.
- Go to the Trade Receivables and Go to Invoices/Payments.
- Go to the Open Items and Choose Export ->To Microsoft Excel.
Keywords
Balance Confirmation, Preview, XML Transformation failed , KBA , SRD-FIN-ACR , Receivables , Problem