SAP Knowledge Base Article - Public

2763832 - XML Transformation failed while Previewing Balance Confirmation for Account Receivables

Symptom

You preview a Balance Confirmation and you receive the error message: "XML Transformation failed".

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Receivables Work center.
  2. Go to the Customers View.
  3. Go to the Balance Confirmation subview.
  4. Show All Balance Confirmation and Find Balance Confirmation ID ABC.  (ABC represents the Balance Confirmation ID).
  5. Choose Preview and Send options.

Error message: "XML Transformation failed".

Cause

This issue could be because of the number of overdue days have a very high value. Business byDesign can only consider < 999 days. To check this please follow the below steps:

  1. Go to the Receivables Work center.
  2. Go to the Customer Accounts subview.
  3. Go to the Trade Receivables subview.
  4. Show All Customers and find Customer Account ID DEF. (DEF represents the ID of the Customer Account).
  5. Open for Example Customer Invoice XYZ. (XYZ represents the Customer Invoice ID).
  6. Choose View.
  7. Go to the Trade Receivables work center and select the Invoices/Payments view.

Under Payment Terms/Due Dates you can see the Days Overdue: If there is more than 999 days, the error message occurs.

Resolution

If the Overdue Dates are 999 days or more you have to use the following workaround:

Instead of viewing the Balance Confirmation in the view you can download the details to Microsoft Excel.

  1. Go to the Receivables Work center.
  2. Go to the Customers view.
  3. Go to the Customer Accounts subview.
  4. Show All Customers and Find Account ID DEF.
  5. Choose view.
  6. Go to the Trade Receivables and Go to Invoices/Payments.
  7. Go to the Open Items and Choose Export ->To Microsoft Excel.

Keywords

Balance Confirmation, Preview, XML Transformation failed , KBA , SRD-FIN-ACR , Receivables , Problem

Product

SAP Business ByDesign all versions