SAP Knowledge Base Article - Public

2764253 - Check Tool: Employee Central Core: HighDate checks return errors

Symptom

Data Issues recognised via Reporting:

  • An Employee's Compensation Information has more than one record with the End Date 31/12/9999 (12/31/9999).
  • An Employee's Job Information has more than one record with the End Date 31/12/9999 (12/31/9999).

Following Check Tools were run and returned errors:

  • CompensationMultipleHighDate
  • CheckLatestCompensationHighDate
  • CompensationStartDateHigherThanEndDate
  • JobInfoStartDateHigherThanEndDate
  • CheckLatestJobInfoHighDate
  • JobInfoMultipleHighDate

Errors in the UI

  • Error when trying to view Compensation History
  • Error when trying to Insert a new Compensation Info record
  • Error when trying to Import Compensation Info and Pay Component Recurring data

 

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

Employee Central

Reproducing the Issue

This issue is not reproducible (no longer possible to create the data in this state).

Cause

The user given in the result of this check (User Sys Id) if there is a problem with the Effective Dated data structure. This problem could indicate one of the following data issues -:

 

The user has more than 1 record with the End Date "12/31/9999"

  • CompensationMultipleHighDate
  • JobInfoMultipleHighDate

The user has one or more records where the Start Date of the record is greater than its End Date

  • CompensationStartDateHigherThanEndDate
  • JobInfoStartDateHigherThanEndDate

The record with the highest Start Date does not have the End Date of 12/31/9999

  • CheckLatestCompensationHighDate
  • CheckLatestJobInfoHighDate

 

For example, you could (to further clarify) run a Person and Employment Export report on the related data to verify the problem. In the below example the user has 2 Compensation Info records with the same End Date (12/31/9999). The start dates could differ, but are more often than not, the same.

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The issue could have been caused by several different reasons (please note that the below bugs and gaps have been fixed already). For example:

  • Defect: When double clicking the "Approve" button in Workflow as the final approver, it was possible the system would create 2 records.
  • Data Issue / Gap: When importing Comp Info data and the record was duplicated in the Import file but processed in different batches by the system.

Resolution

This issue is classed as a data issue and requires the data be corrected manually. Therefore the solution is to perform a Full Purge import of the data. There is no way to correct the end-date manually either via the UI or Import.

Regardless of which check returned errors, the resolution is always the same. Full Purge Import of the related data, with the End Date column maintained as blank (null).

 

IMPORTANT INFORMATION WHEN WORKING WITH COMPENSATION INFORMATION: Please ensure that you take a backup of both the Compensation Information AND the Pay Component Recurring data before performing any Full Purge imports. Full Purge import will delete ALL the data for that HRIS Element and replace it with the data from the import file.

 

Solution Steps for Job Info related checks:

  • Create a "Person and Employment Export" Ad Hoc Report, and only select columns from the Job Info column set. Filter the report as needed and then generate it and save the file somewhere safe.
  • Navigate to Admin Center > Import and Export Data > download the Import Template for Job Information.
  • Follow article 2489526 to Full Purge import the Job Info data for the user.

 

Solution Steps for Compensation Info related checks:

  1. Create a "Person and Employment Export" Ad Hoc Report, and only select columns from the Compensation Info column set. Filter the report as needed and then generate it and save the file somewhere safe.
  2. Create a second "Person and Employment Export" Ad Hoc Report, and this time only select columns from the Pay Component Recurring column set. Filter the report as needed and then generate it and save the file somewhere safe.
  3. Navigate to Admin Center > Import and Export Data > download the Import Templates for both Compensation Info and Pay Component Recurring.
  4. Follow article 2413486 to Full Purge import the Compensation Info data.
  5. Follow article 2494885 to Full Purge import the Pay Component Recurring data.

 

TIP: If you leave the End Date column blank in the import template, the system will set the date automatically. So technically all you need to do is export the data, clear the "End Date" column and re-import it.

 

See Also

  • 2413486 - Correct or Update Compensation Information record via Import in Full Purge mode
  • 2494885 - Correct or Update Pay Component Recurring or Pay Component Non Recurring Information record via Import in Full Purge mode
  • 2489526 - Correct or Update Job Relationships Information record via Import in Full Purge mode
  • 2317955 - Correct or Remove Job Information record via Import in Full Purge mode

Keywords

compInfo, jobInfo, high date, CompensationMultipleHighDate, payComponentRecurring, Full Purge, ec core, check tool, 12/31/9999, 31/12/9999, ECT-110678, ECT-110472, CompensationMultipleHighDate, CheckLatestCompensationHighDate, CompensationStartDateHigherThanEndDate, JobInfoStartDateHigherThanEndDate, CheckLatestJobInfoHighDate, JobInfoMultipleHighDate , KBA , LOD-SF-EC-CMP , Compensation Information & One-Time Bonus , Problem

Product

SAP SuccessFactors Employee Central all versions