SAP Knowledge Base Article - Public

2764341 - Check Tool: Employee Central Core: EffectiveLatest checks return errors

Symptom

The following Check Tools return errors:

  • EffectiveLatestRecurringCompensationChange
  • EffectiveLatestCompensationChangeForLastChange
  • EffectiveLatestRecurringCompensationChangeNotNull
  • EffectiveLatestCompensationChangeNotNull
  • EffectiveLatestJobChangeNotNull
  • EffectiveLatestJobChangeForNotLastChange
  • EffectiveLatestJobChangeForLastChange

You are unable to add Payment Information to a user due to the error "Sorry, it is not possible to maintain payment information if there is no job information or no country/region in job information" even though the user does have Job Information data.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

Employee Central

Reproducing the Issue

"EffectiveLatest" Check Tools failed

  1. Go to Admin Center > Check Tool > Employee Central Core
  2. Run one of the following checks -:
    • EffectiveLatestRecurringCompensationChange
    • EffectiveLatestCompensationChangeForLastChange
    • EffectiveLatestRecurringCompensationChangeNotNull
    • EffectiveLatestCompensationChangeNotNull
    • EffectiveLatestJobChangeNotNull
    • EffectiveLatestJobChangeForNotLastChange
    • EffectiveLatestJobChangeForLastChange

 

Error in Payment Information UI's

Please refer to 2342583 - Payment Information Error: "Sorry, it is not possible to maintain payment information if there is no job information or no country in job information"

Cause

In B1508, a new column (internal flag) was added to the database tables for Job Info, Compensation Info & Pay Component Recurring tables to track the "Effective Last Change". The job did not run for all customers at point of release in b1508 indicating that Historical records are not updated.

Resolution

To resolve the issue, a job must be run from Provisioning to set the flag correctly for all records. Please note that this job will not change/manipulate or damage data in any way. The job will set the flag appropriately for all records.

WARNING: If you have errors after running any of the "HighDate" checks, then please ensure that these are fixed first before proceeding with running either of the "Initialize effective latest change flag" jobs. The checks you should run first are -:

  • CompensationMultipleHighDate
  • CheckLatestCompensationHighDate
  • CompensationStartDateHigherThanEndDate
  • JobInfoStartDateHigherThanEndDate
  • CheckLatestJobInfoHighDate
  • JobInfoMultipleHighDate

 For any HighDate check that returns an error you can refer to article 2764253 - Check Tool: HighDate checks return errors

 

Running the "Initialize effective latest change flag" job

Running this job is fairly simple, but you do want to schedule it for a time when users are not actively working in the system (overnight or over the weekend is generally best). Depending on which checks failed you should run the corresponding job, but there is no harm in running both jobs.

  1. Go to Provisioning > Manage Scheduled Jobs
  2. Create the corresponding job (depending on the "EffectiveLatest" check that returned errors):
    • Initialize effective latest change flag for comp info
    • Initialize effective latest change flag for job info
  3. Run the job out of working hours

 IMPORTANT: Do not schedule this job to run on a recurring basis. This job must simply run once, and it will not need to be run again.

Once the job is completed, please run the Check Tool again to verify all records are properly flagged.

View Post Release B2205 -: 3169863 - Employee Central Release FAQ - First Half 2022 (1H 2022)

We’ve merged 3 end-date checks into 1 check. These checks are no longer listed:

- CheckLatestJobInfoHighDate

- JobInfoStartDateHigherThanEndDate

- JobInfoMultipleHighDate

If the check returns issues, a quick fix is offered for the system to automatically correct the issues for you

Configuration Requirements

Apart from the check tool, you also must have enabled the applications for which you want to run the checks. For example: Employee Central.

Role-Based Permission Prerequisites

You have the following Administrator > Check Tool permissions:

  • Access Check Tool
  • Allow Configuration Export
  • Allow Check Tool Quick Fix

Related Information:

 Please do reach out to Product Support if:

  • You are a customer and cannot schedule the Provisioning Job yourself
  • You have run the job multiple times but you find that the Check Tool still returns errors 

Also View: 2472648 - Check Tool: How to check your SuccessFactors configuration

  1. Open Check Tool
  2. Go to Check Tool
  3. Select Application 'EC Core'
  4. tick: title
  5. Run

See Also

  • 2764253 - Check Tool: HighDate checks return errors
  • 2472648 - Check Tool: How to check your SuccessFactors configuration
  • 3169863 - Employee Central Release FAQ - First Half 2022 (1H 2022)

Keywords

EffectiveLatestRecurringCompensationChange, EffectiveLatestCompensationChangeForLastChange, EffectiveLatestRecurringCompensationChangeNotNull, EffectiveLatestCompensationChangeNotNull, EffectiveLatestJobChangeNotNull, EffectiveLatestJobChangeForNotLastChange, EffectiveLatestJobChangeForLastChange, ec core, jobInfo, compInfo, compensation information, job, Check Tool , KBA , LOD-SF-EC-CMP , Compensation Information & One-Time Bonus , LOD-SF-EC-JOB , Job Information , Problem

Product

SAP SuccessFactors Employee Central all versions