SAP Knowledge Base Article - Public

2765281 - Access Restrictions for Service Technician Not Working

Symptom

You are creating a Ticket and when searching for Service Technicians on the value help, you can see more values than expected and configured on access restrictions.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Service work center.
  2. Select the Tickets view.
  3. Click on New.
  4. On the Service Technician field, click on the value help to search for Service Technicians.
  5. You can see all Service Technician records that are expected but also Service Technician ID XYZ (XYZ represents the Service Technician ID) that you should not see.

Cause

Service Technician XYZ is a Service Agent.

Resolution

The Service Technician value help, same as other Employee value helps, considers Internal Employees, maintained on the People work center, and External Employees, maintained on the Business Partners and Partner work centers.

For Employees and Partners, we can maintain restriction on Business Users or Business Roles. However, Service Agents cannot be restricted and will be shown for all users.

Keywords

Service Agent ; Employee ; Access Restriction ; Service Technician ; Ticket , KBA , LOD-CRM-EMP , Employee , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions