Symptom
Comments made are not reflected in the e-mail notification to approver for cancellation of leave. The template is using: [[RECENT_COMMENT_POSTED]] token, 'Recent Comment Posted' reference mapping or 'Initiator Comment' reference mapping.
When the leave request is raised, the field comment is correctly posted in the email generated to the approver. But when the employee cancels the leave with a different comment, the comment does not appear in the email notification.
Environment
Success Factors Employee Central - Time Off
Reproducing the Issue
1. Create an email notification template (or in standard template) with the token [[RECENT_COMMENT_POSTED]] or 'Recent Comment Posted' reference mapping or 'Initiator Comment' reference mapping
2. Cancel an approved leave with new comment to trigger cancellation workflow
3. Cancellation workflow does not have the comment posted
Cause
Cancellation workflow creates a new workflow request and therefore comment is getting lost because we do not maintain the comment history in the employee time object and the comment is not passed to the workflow. So when sending email notification, the comment in cancellation workflow is blank as the comment in the Employee time object was associated with the initial approval workflow.
Resolution
- There are two email notifications received, one for the workflow initation send to the approver, another about the comment posted. So there is no information loss for the customer
- An open enhancement has been created, which will be taken up in the future
Keywords
Comment, cancellation workflow, leave, time off, employee central, employee time, Recent Comment Posted, Initiator Comment, TIM-8369, , KBA , LOD-SF-EC-TIM , Time Off , LOD-SF-EC-DOC , Document Generation , Product Enhancement