Symptom
You have integrated ISU with Cloud For Customer (C4C), and enabled the configuration to configure the below standard fields in the service request work center:
-
PoD External ID
-
Premise Ext. ID
When you create Service Tickets from external system using the OData, in metadata structure you can not find the above fields for Premise and POD in service request as a part of this OData metadata.
Environment
SAP Cloud For Customer
Reproducing the Issue
When you check the above mentioned fields are missing in the metadata:
https://mytenant.crm.ondemand.com/sap/c4c/odata/v1/c4codata/$metadata
https://mytenant.crm.ondemand.com/sap/c4c/odata/v1/c4codataapi/$metadata
Cause
This requirement is not a part of the standard roadmap. This can be achieved via SDK.
Resolution
The Premise/POD ID is stored in Service request BO as installation point. You may follow the below approach to capture the Utilities technical data while ticket creation.
- Create custom field to store Premise ID or POD ID (Note that only one of these can be stored at a time for a service request) in the after modify of Service request
- Determine the Install point UUID from the Premise ID (queryPremise BO and fetch Install Point UUID through association)
- Populate this Install Point UUID in the MainServiceReferenceObject node of the Service Request
See Also
Note: Attached is the sample code snippet for this logic with the steps to achieve this in SDK.
Keywords
ISU integration, ISU Metadata, ISU Odata, On premise Fields in ODATA , KBA , LOD-CRM-INT-API , OData API (C4C Only) , Problem
Product
Attachments
| ISU_Premise_ServiceRequest_DATA.docx |
SAP Knowledge Base Article - Public