SAP Knowledge Base Article - Public

2765520 - An Inbound E-Mail is Shown With the The Error 'Please Enter a Party With Role XYZ' in The Web Service Message Monitoring

Symptom

When checking the Web Service Message Monitoring, you can see multiple erroneous Inbound E-Mails with the following Error message:

 'Please Enter a Party With Role XYZ'

(XYZ represents the Party Role Description)

Environment

SAP Cloud for Customer - Sales

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Select the General Settings view.
  3. Select the Web Service Message Monitoring hyperlink.
  4. Filter for Erroneous Messages.

You can see multiple inbound E-Mails with the following Error:

 'Please Enter a Party With Role XYZ'

Cause

The system cannot create the E-Mail Activity in the system, because Party XYZ was marked as mandatory and the Determination for the Role was configured in a way that it does not work for incoming E-Mails.

For example:

In the Fine-Tuning Activity for Activities you have marked the party role Sales Manager as mandatory and configured the Determination for that party role, so that the logged in User will automatically be maintained in the E-Mail Activity with this party role.

When an inbound E-Mail is sent to the system, this will create an E-Mail Activity automatically. But since there is no logged in User involved in this process for E-Mails, the mandatory Party Role cannot be added and therefore results in an error.

Resolution

  1. Go to the Business Configuration work center.
  2. Select the Overview view.
  3. Filter for and open the Activity for Activities.
  4. Select the hyperlink to maintain Involved Parties for E-Mails.

Here you can see, which roles are marked as mandatory and you can check the automatic determination of each Party.

Keywords

Enter Party Role Inbound E-Mail Activity , KBA , LOD-CRM-ACT , Activities , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions