SAP Knowledge Base Article - Public

2765680 - Error "Asset has no Registered Products" When Adding Asset ID To New Point of Engagement

Symptom

You receive the error "Asset has no Registered Products" when adding a value to the Asset ID field during Point of Engagement creation.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Activity Planner work centre.
  2. Go to the Point of Engagement (PoE) view.
  3. Click New.
  4. Select any value from the ovs for Asset ID.
  5. You receive the error "Asset has no Registered Products".

Cause

This error happens, when you select a product value which is not assigned to a registered product.

The field Asset ID refers to the Product ID of a product which is maintained in a Registered Product.

Please note that the Asset ID is not mandatory and you can create PoE without it.

Resolution

If you want a Product related to your PoE, choose a product ID which is assigned to a Registered Product.

  1. Go to the Products work centre.
  2. Go to the Registered Products view.
  3. In the OWS, make the column Products visible.
  4. Open a Product which is maintained for a Registered Product.
  5. Use that Product Id as Asset ID when creating your Point of Engagement.

See Also

SAP Cloud for Customer Help Portal:

  • Scope and Configure Perfect Store
  • Create Points of Engagement
  • Define Points of Engagement

Keywords

Asset ID, Point of Engagement, new, PoE, Registered Product, error, Product, Activity Planner , KBA , LOD-LE-PSP , Perfect Store , LOD-LE-IBA , Installed Base Data Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions