Symptom
When simulating a call in Fiori using the CTI adapter, the Accept and Reject button are not available.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Open the CTI Client Adapter.
- Simulate a Call in Fiori. The Accept and Reject button are not be available.
Cause
To have both buttons available a Widget must be configured in Fiori UI
Resolution
The Widget needs to be developed by the company CTI provider. In the Widget multiple button can be setup like Accept, Reject, Transfer etc.
In Accept scenario, once the call is accepted there is a payload sent from CTI to Cloud for Customer. A payload example is can be found in the following guide.
For Reject scenario a call, if agent rejects the call the user can choose to not send the information to Cloud for Customer.
Keywords
CTI; Reject; Accept; Button; , KBA , LOD-CRM-LA , Live Activity , How To