Symptom
- Report file is not found on the server or is purged.
- Unable to download a report due to the following error:
Validation Error - You must correct the following error(s) before proceeding: The Report File {0} was not found on the server. It may have been purged.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Log in as a Learning admin > Go to Reports > Navigate to the "Report Jobs" tab > Under "Actions", click "Download".
Cause
The "Report_System" configuration is not configured accordingly to the desired number of days after which background reports should be removed from storage, thus report file has been purged.
Resolution
- Learning admin side > System Administration > Configuration > System Configuration >
- Look for "REPORT_SYSTEM" > Edit the system configuration:
- Search for "asyncStorageTTLDays=" and change the number to the desired number of days after which background reports should be removed from storage >
Note: For example, if you set "asyncStorageTTLDays" to 90, then SAP SuccessFactors Learning purges background reports (and the data that was reported) that are older than 90 days.
- Apply Changes:
See Also
Keywords
lms, learning, purged, purge, report, store, number, day, storage, report_system, server, not, found, file, download, error, unable , KBA , LOD-SF-LMS-REP , Reporting Data , LOD-SF-LMS , Learning Management System , Problem